Page 1 of 1

Prune button not working

Posted: Fri Jun 14, 2019 11:47 am
by FuxieDK
I have entries over 4 month old, yet pressing Prune says "0 pruned"


Posted: Sun Jun 16, 2019 8:33 am
by bringoutyourdead
Are you by any chance running an addon that captures Blizzards warning and error messages?
if so it is hiding what I expect what is causing your problem.

Here is what I did.
After some issues, I was able to admin into the server administration, find and download your latest upload file.

After renaming the file to again be compatible with CensusPlus, I copied it into an account that allows access to the EU servers.
I created a new horde character on Draenor and logged in.
After a little bit of trial and error I got the CensusPlus window to populate with data, without having to wait for a long census run to complete.

I then tried a standard [PRUNE] button press, and after a bit got a non-fatal error "script ran too long".

I then tried a commandline "/census serverprune" this ran without problem.. but then it would since you only play on Draenor and there was nothing else to prune.
After logging out and comparing the new modified CensusPlus data with the original that I had downloaded, I did notice that at least some older character data did get pruned.
I then decided to do a series of: login, prune, logout.. with the hope that eventually the data would again fit comfortable with the allotted space allowed by Blizzard.

I was little surprised when on the next prune cycle the process ran to completion and 98,500 characters were pruned from your original >133,000 characters in the CensusPlus data table.


Your data file is big >19MB at >133,000 characters, but it is intact with no errors.
I believe you also ran into a processing resource issue, as I had while testing.
You should be able to fix the problems by doing the following.

Login on Draenor, in CensusPlus turn off the auto-census, logout of the realm.
back out on the wow client until you get to the addons button and disable all of your addons EXCEPT for CensusPlus.
Login again on Draenor and press the [PRUNE] button in the CensusPlus window or type on the chat line /census prune
If you hit a resource limit, logout and then repeat the above login/prune/logout cycle until prune runs to completion.
again back out on the wow client and reset your addons to what you normally use and you should be back in normal play conditions.

Posted: Sun Jun 16, 2019 8:49 am
by bringoutyourdead
Oh and as an added side note. your upload at over 19MB is nearly 3 times larger then the next largest upload during the last few weeks in the upload directory on the server.

On the other hand the super duper census taker Padanfain uploads nearly 5 time more character updates .. but then he is only interested in the latest Census data and purges all the time.

Posted: Mon Jun 17, 2019 1:22 am
by FuxieDK
I do have BugGrabber/BugSack installed. But I didn't think to check for errors there, since I got the "0 pruned" message. Silly me.

The file is large (well huge) since apparently, old entries haven't been pruned for 3+ months. Then it just keep adding new ones. And since I use UniUpload, you can upload files bigger than 10MB and I don't need to check for size before upload.

When I open the UI, it can take a good 15 seconds where the game is frozen, so resources might indeed be stretched thin ;)

After Blizzard finally allowed us to have all 50 toons on same server, I moved my off-server toons to Draenor, so I haven't had any toons on other servers, except for a few census-only toons I haven't had time to log in, the last few month.

Do you want me to look through BugSack and post what I find? Or did you replicate it yourself?

Posted: Mon Jun 17, 2019 6:38 am
by bringoutyourdead
No need... just from your latest comment.. tells me you were able to push the client to the edge.

Posted: Wed Jun 19, 2019 10:43 pm
by FuxieDK
I pressed the button again today. "0 pruned".

Then I did "/census prune" command: 97363 pruned.. Very strange.

Neither time, did I get anything in BugSack, but size have shrunk to ~5,7MB :)

I'll keep an eye on it, trying to see if the problem comes back.

Posted: Sun Jul 14, 2019 6:59 am
by FuxieDK
Update after 3-4 weeks.

Even through I managed to shrink the size, it still continue to grow, as Prune button still returns "0 pruned"
Manual "/census prune" just cut 23000+ entries.

Still nothing in BugSack/BugGrabber