WarcraftReamls.com
  FAQFAQ    SearchSearch    MemberlistMemberlist    UsergroupsUsergroups   RegisterRegister 
  ProfileProfile    Log in to check your private messagesLog in to check your private messages    Log inLog in 
Minor bug in UI

 
Post new topic   Reply to topic    WarcraftRealms.com Forum Index -> CensusPlus UI Mod Bugs
View previous topic :: View next topic  
Author Message
FuxieDK
Census Taker


Joined: 22 May 2008
Posts: 616
Location: Copenhagen, DK
WR Updates: 4,395,489
FuxieDK WR Profile

PostPosted: Sat Jul 30, 2016 6:32 am    Post subject: Minor bug in UI Reply with quote

First time (after login) I open UI and starts to move it, "Show Chars" button does not follow the window..
When I drop the window, 1-2 seconds later the button finds its place and from now on, it follows the movement of the window....... until next login..


_________________
Doing census mainly on Draenor; Raluf - Nimsay - Lusmo - Quixx - Sosyan - Garthog - Trubin - Zalistra - Zesmi and Djaang
Back to top
View user's profile Send private message
bringoutyourdead
Forums Admin & general flunky


Joined: 07 Nov 2008
Posts: 1214
Location: Silicon Valley, CA, USA
WR Updates: 9,182,216
bringoutyourdead WR Profile

PostPosted: Sun Jul 31, 2016 8:34 pm    Post subject: Reply with quote

Had not noticed that before.

I think it is an artifact of Connected Realms.

Before those happened, we could always be sure of what realm we were looking at so preloading the census data window before a census run was not a problem.

After Blizzard started Connected Realms we can not be sure what realms we are really looking at until a Census process starts and populates the found realms list.

The Character list button was anchored to the nearest graphic element... which happened to be the tenth Guild entry item.

What is occurring here is that the initial placement is defined by the main XML file. Then when you move the window, the anchor isn't tracking to the guild item (since it doesn't have data yet).

When a Census is running that data happens and the anchor becomes valid.. the button moves to where it should be.
Otherwise there is a low frequency refresh of the window.. that will fix the button condition when you stop moving the window.

Since this is a very minor self correction graphics issue.. I wasn't going to bother fixing... but
in trying to figure out what was really happening.. I ended up changing the anchor point and fixed the issue.

It will be part of the next CensusPlus update.

Thanks for reporting the problem.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    WarcraftRealms.com Forum Index -> CensusPlus UI Mod Bugs All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
WarcraftRealms.com  


Powered by phpBB © 2001, 2005 phpBB Group