WarcraftReamls.com
  FAQFAQ    SearchSearch    MemberlistMemberlist    UsergroupsUsergroups   RegisterRegister 
  ProfileProfile    Log in to check your private messagesLog in to check your private messages    Log inLog in 
page update delay times

 
Post new topic   Reply to topic    WarcraftRealms.com Forum Index -> WarcraftRealms.com Bugs
View previous topic :: View next topic  
Author Message
bringoutyourdead
Forums Admin & general flunky


Joined: 07 Nov 2008
Posts: 587
Location: Silicon Valley
WR Updates: 7,081,179
bringoutyourdead WR Profile

PostPosted: Sat Jul 13, 2013 10:50 am    Post subject: page update delay times Reply with quote

Metalbeast could you make a post with a general listing of what pages update soon after upload processing and which are delayed due to caching and where delayed the expected update cycle times?

This is something I've always been a bit confused about.

Yesterday I spent a good portion of the day playing whack a zero (or one) on the US data center realms. All was looking fine until I found a realm that didn't seem to want to display complete updates.. most pages with references to the problem realm seemed to update but not the player activity (aka Realm Activity) page. I waited 10 hours and checked the realm still no updates and started a bug report messate.. then deleted it.

This morning the update was posted... but it did bring another oddity into focus.

Take the following realms Burning Blade and Burning Legion
I did both realms both factions one after the other.. during hour 12 and 13 uploading each hour.
Sometime during hour 14 I found that Burning Blade had fully updated its related pages including player activity but Burning Legion while it appeared to have updated most pages the player activity still showed no activity. As you can see I banged on Burning Legion a few more times during the day to see if I could get that page to update.. It didn't until after I gave up checking around hour 22. This morning all was updated.

The question I have is why Burning Blade showed update not long after upload processing was finished... but Burning Legion took some time greater then 10 hours to display?
Back to top
View user's profile Send private message
bringoutyourdead
Forums Admin & general flunky


Joined: 07 Nov 2008
Posts: 587
Location: Silicon Valley
WR Updates: 7,081,179
bringoutyourdead WR Profile

PostPosted: Sun Jul 14, 2013 1:11 pm    Post subject: Reply with quote

further info

Looking at two realms Andorhal and Blade's Edge

From the current Server Submissions page
Andorhal 7 7 <-- NY data center, EDT
Blade's Edge 7 7 <-- note this is a NY data center PDT realm the same as both myself and the website.



From my CensusPlus.lua TimesPlus branch
["Andorhal"] = { <-- note for both factions census during 7 different hours of the day over multiple days
["Horde"] = {
["2013-07-13&14:26:00"] = "14&12&7&8&11&10&8&10&6&10&7&2&1&1",
["2013-07-12&23:27:00"] = "9&15&11&10&12&11&7&8&12&8&5&5&0&2",
["2013-07-13&20:27:00"] = "14&15&6&13&5&10&9&6&10&15&6&1&1&0",
["2013-07-14&0:11:00"] = "16&9&8&8&3&10&5&7&9&15&4&0&2&0",
["2013-07-13&12:47:00"] = "7&9&8&9&5&7&6&6&3&9&3&3&1&0",
["2013-07-13&19:49:00"] = "15&11&8&8&5&13&8&9&11&12&4&2&0&0",
["2013-07-14&13:36:00"] = "3&5&11&7&5&9&8&10&7&14&3&2&0&0",
},
["Alliance"] = {
["2013-07-14&0:9:00"] = "6&12&4&5&6&3&7&5&12&6&3&1&0&1",
["2013-07-13&19:45:00"] = "7&12&1&3&1&5&7&4&9&10&5&3&1&0",
["2013-07-12&23:24:00"] = "5&10&5&5&4&4&12&3&10&7&3&1&1&1",
["2013-07-14&13:33:00"] = "11&10&5&7&5&1&5&3&7&7&3&1&0&1",
["2013-07-13&12:34:00"] = "7&7&3&7&4&3&6&5&7&7&0&2&0&0", <-- returned to WoW and found disconnected so ran again
["2013-07-13&12:40:00"] = "6&6&2&8&3&5&8&3&6&8&0&2&0&0",
["2013-07-13&14:22:00"] = "7&9&1&6&2&4&6&2&8&2&1&2&1&2",
["2013-07-13&20:24:00"] = "6&8&1&9&3&4&6&5&9&9&4&2&0&0",
},
},


["Blade's Edge"] = { 5 different hour for horde and 6 for alliance
["Horde"] = {
["2013-07-13&11:36:00"] = "25&30&21&28&15&20&12&21&30&32&17&8&0&1",
["2013-07-13&16:57:00"] = "29&43&25&43&21&29&28&32&32&30&25&4&5&2",
["2013-07-13&17:41:00"] = "34&45&28&42&19&31&24&30&38&34&27&10&2&4",
["2013-07-13&21:19:00"] = "27&39&23&35&20&35&24&22&37&28&34&8&1&0",
["2013-07-13&10:25:00"] = "13&34&21&28&16&20&17&18&28&28&17&5&1&0",
},
["Alliance"] = {
["2013-07-13&16:52:00"] = "25&45&28&27&22&20&34&23&35&31&29&12&5&1",
["2013-07-13&17:35:00"] = "35&41&23&36&29&27&28&13&42&33&29&10&1&2",
["2013-07-13&11:31:00"] = "25&36&23&36&23&28&24&18&39&36&23&6&2&1",
["2013-07-13&21:16:00"] = "38&60&26&30&20&30&28&15&50&30&25&6&0&1",
["2013-07-13&17:31:00"] = "36&42&21&34&27&26&32&14&45&32&26&9&0&2", <-- found disconnected did census again
["2013-07-13&9:31:00"] = "22&43&12&34&15&15&24&20&21&23&20&5&2&0",
["2013-07-13&10:22:00"] = "28&37&16&41&18&20&23&15&35&29&25&5&1&1",
},
},


And the just refreshed pages of Player (aka Realm) activity graph pages

Andorhal

{sigh these didn't screen scrape very well}

Hour, Alliance Average, Alliance Entries, Horde Average, Horde Entries, A:H
0 0 0 0 0
1 0 0 0 0
2 0 0 0 0
3 0 0 0 0
4 0 0 0 0
5 0 0 0 0
6 0 0 0 0
7 0 0 0 0
8 0 0 0 0
9 0 0 0 0
10 0 0 0 0
11 0 0 0 0
12 56 2 72 1 1 : 1.3
13 0 0 0 0
14 48 1 88 2 1 : 1.8
15 0 0 0 0
16 0 0 0 0
17 0 0 0 0
18 0 0 0 0
19 0 0 0 0
20 0 0 0 0
21 0 0 0 0
22 0 0 0 0
23 68 1 108 1 1 : 1.6

Overall 57 4 89 4 1 : 1.6

-- looking at the graph you can see for Horde 4 distinct inflection points which provide the endpoints for the lines that are displayed. (with a possible at the 0 hour but hard to tell on that one.) but the detail table that goes with the graph is only showing 3 of the 7 data points that have been uploaded!!!
I am assuming that for the table and entry is marked where the census time stamp is in the range of hour:00 to Hour:59. Alliance shows the double run during hour 12 which is valid.. but Horde show a double at hour 14 which doesn't fit my assumption. (and since I appear to have been the only one doing census runs taking this realm from 0 0 to 7 7 census/30 days... my data should be correct)
I tried a different assumption of each hour being centered at the top of the hour (hour-30minutes - hour - hour+30 minutes) {an odd but possible setup} and while it would fix one data point for Horde it introduced another ... so that is by examination a bad assumption.

Blade's Edge

Hour Alliance
Average Alliance
Entries Horde
Average Horde
Entries A:H
0 139 2 0 0
1 0 0 0 0
2 0 0 0 0
3 0 0 0 0
4 0 0 0 0
5 0 0 0 0
6 0 0 0 0
7 0 0 105 2
8 0 0 0 0
9 249 1 0 0
10 287 1 240 1 1.2 : 1
11 311 1 251 1 1.2 : 1
12 0 0 0 0
13 0 0 0 0
14 0 0 0 0
15 0 0 0 0
16 0 0 0 0
17 0 0 0 0
18 0 0 0 0
19 0 0 0 0
20 0 0 0 0
21 0 0 0 0
22 0 0 0 0
23 0 0 0 0

Overall 247 5 199 4 1.2 : 1

Blade's Edge activity graph shows for Alliance 2 end points and 4 inflection points for a total of 6 data points which matches my upload info.
the chart shows oddities.. the time stamps tdon't match the uploaded data nor the number of data points. even though the graph does appear to match my upload in data points and data times.
Back to top
View user's profile Send private message
bringoutyourdead
Forums Admin & general flunky


Joined: 07 Nov 2008
Posts: 587
Location: Silicon Valley
WR Updates: 7,081,179
bringoutyourdead WR Profile

PostPosted: Mon Jul 15, 2013 1:45 pm    Post subject: Reply with quote

And after another days delay... I can say that eventually it seems the detail charts do finally display the correct data.

I did a compare on Andorhal with my Timesplus section which I imported into Openoffice calc. and did match nearly all entries... except one which I believe might have an single previous census run.

So the graph and finally the detail chart do match valid data.... eventually.

I do wish the A:H column was adjusted a bit to the right, I kept confusing the Horde entries number by visually linking the number in that column with the alliance side of the A:H column.. checked with IE and Firefox

Even though all the table elements are right aligned the A:H column isn't large enough to provide visual separation.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    WarcraftRealms.com Forum Index -> WarcraftRealms.com Bugs All times are GMT - 6 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
WarcraftRealms.com  


Powered by phpBB © 2001, 2005 phpBB Group