Select Language

Updated version available! Get it here!

Rollie

 
Version 1.5 is up which implements Blizzard's new Interface version (4211). You can get it here:

http://www.warcraftrealms.com/censusplus.php

This also corrects a bug in the US version. Please note the changes from the previous version:

-Updated interface version number to 4211 which syncs up EURO and US versions.
-Added an initial selection dialog that will set your CensusPlus version to EURO or US. This MUST be set correctly for data to be reliable for US vs EURO servers. PLEASE PLEASE PLEASE set this correctly! I have absolutely no way to guarantee that the data I receive is from a EURO or US server so I am forced to rely on you, the users! Please don't let me down! Note that your set locale can be seen in the upper left corner. You should see either "Census+ v1.5 US" or "Census+ v1.5 EU" in the top bar of the Census window.
-Fixed a time bug issue with offset times if you had them set in Cosmos.
-This version should be nearly fully French and German localized with the exception of recently added strings. If you find the strings to be incorrect, please let me know as some of the translators have confessed not being 100% sure they are 100% correct.
-I will have another version coming soon with many requested features. For this release I was concentrating on finding as good a solution as possible for localization and handling of EURO and US data.
-Note: If you are a EURO player, when you start this new version, it will clear out all your previous data in order to make sure that uploaded data is reliable. If you change your locale, it will also purge your database to best maintain reliable information


Please grab the latest version. Tomorrow I will no longer accept any data from any version prior to 1.5 so grab the latest today so you don't have to deal with it later!

EURO users: You may begin submitting data, but you MUST use this new version to do so (version 1.5).


EDIT: I found a small bug with the latest release. I have uploaded a new version (1.51) ready for download. It won't cause any data errors, but is what is causing the USServerName servers to appear.

EDIT2: I will no longer accept data from earlier versions of CensusPlus. In order to submit data to the site, you MUST use the latest version of CensusPlus (v1.51). Thank you for understanding, and sorry for any inconvience.
Anonymous says:
February 16,2005 at 9:23
Thanks for the fast work on integration of the eu-servers!
('cause no one else mentioned a thx untill now...)

I really like this site and the service it provides, and I'm looking forward to collect census data again tonight. I just got to find out how bad horde ist underpopulated on my very own server...

Keep up the good work. It's appreciated.

Marverick.
Anonymous says:
February 16,2005 at 16:16
Hello,

i just made a Census on my Server (DE-Azshara) with the german Client and it seems to me, that this vesion still cannot handle the word "J?ger" (german for hunter).
I suppose this, because i didn?t find any hunters while doing the census and that seems a little bit strange to me.

so long

Dadriel

P.S.: Excuse my bad english, i know why I'm playing on a german server ;)
Anonymous says:
February 16,2005 at 18:0
Just got v1.51. Selecting EU / US worked fine, but there's a problem with "?" "?" and "?" in the german Version.

Button names dont show up correctly when theres an "Umlaut" in the name, but that really doesnt matter.

More important, the whole hunter-population doesnt show up ingame. Hunters are counted and submitted to the site just fine, but I cant view them in game.

As a hunter myself, thats quite a problem.

Code in v 1.51 is like (localisation.lua):

CENSUSPlus_HUNTER = "J?ƒ¤ger";

I changed that to:

CENSUSPlus_HUNTER = "Jäger";

As suggested some weeks ago on this forum. Works fine for me. Hunters are showing up. Dont know if this would lead to some bug with counting, but I dont think so, 'cause this exact same string worked before.

Only question is: Was there a good reason to change the string at all I dont see? Or just rename "J?ƒ¤ger" to "Jäger"?

Slauncha.

Marverick.
Rollie says:
February 16,2005 at 18:31
Not really having a very firm grasp of the localization and an even less grasp of german or french, this is very possible. I'll fix 'em as we see 'em though, and thank you for bringing this up!

I'll get it changed very soon!


EDIT: Okay, so this is odd... when I open my localization.lua file, what I see is what you say you changed it to. I see:

Jäger

Instead of what you posted. Blarg!

Also, while you are at it, can you translate these to German for me?

CENSUSPLUS_US_LOCALE= "Select if you play on US Servers";
CENSUSPLUS_EU_LOCALE= "Select if you play on EURO Servers";
CENSUSPLUS_LOCALE_SELECT= "Select if you play on US or EURO servers";
Kitaka says:
February 16,2005 at 19:50
damn where will be the data saved ?? I can't find any hint for that point
Rollie says:
February 16,2005 at 20:6
The data is stored in your SavedVariables.lua file in the CensusPlus_Database variable.
Kitaka says:
February 16,2005 at 20:20
mhm i can't see any changed after a session with wow and census..

i have another problem with the images. i can'T see them, i see a ?

and when i move over it, i will get a failure.


But the mainproblem is the data. First of all i set the date, and the i start the search. no failure anyway but no changes n the savedvariables.lua

mabey there is a problem with the location of my file?
Kitaka says:
February 16,2005 at 20:23
..
Kitaka says:
February 16,2005 at 20:24
im sorry, after i reloged the data was in the file.

Mabey you have a clue to solve the problem with the images?
Rollie says:
February 17,2005 at 1:26
I usually use Visual Studio, which I would think would be safe. I'll see if I can find out what's up. Do you have an editor you could recommend? Or it may even be my Windows settings, who knows. This localization stuff is very new to me.

Thanks for the translations of those strings!
Rollie says:
February 17,2005 at 1:37
Okay, after digging a bit, I found where to set the encoding for Visual Studio.

I have made changes to the localization file and hopefully this is now remedied. Please let me know if this is not the case!
Anonymous says:
February 17,2005 at 11:17
Playing on WoW EU, using Cosmos Alpha 1.455. I get this error, which won't let me use Census+ at all, when logging into the game:

String: Interface\AddOns\CensusPlus\localization.lua
Line: 1
Count: 1
Error: unexpected symbol near `?--------------------------------------------------
String: Interface\AddOns\CensusPlus\CensusPlus.lua
Line: 105
Count: 1
Error: table index is nil
--------------------------------------------------
String: AutoStart:OnLoad
Line: 2
Count: 1
Error: attempt to call global `Census_AutoStartOnLoad' (a nil value)
--------------------------------------------------
String: CensusPlus:OnLoad
Line: 2
Count: 1
Error: attempt to call global `CensusPlus_OnLoad' (a nil value)
Anonymous says:
February 17,2005 at 11:23
I get the same problem!
Rollie says:
February 17,2005 at 11:28
Working to track this down, please see this thread:

http://www.warcraftrealms.com/forum/viewtopic.php?t=197

Leave a Reply

You must be Logged In in order to post comments.


 
Advertise Here!